Re: no auto-summaryの使い方(問題ID: 13744)

この質問の投稿一覧へ

なし Re: no auto-summaryの使い方(問題ID: 13744)

msg# 1.2
depth:
1
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2013-10-29 21:09 | 最終変更
arashi1977  長老 居住地: 広島  投稿数: 1715
以下のコンフィグを参考に入れてみてください。
それぞれのルータで「no auto-summary」を消す(= auto-summary コマンド投入)してどのようにルーティングテーブルが変わるかを見てみるとわかると思います。

RouterA:
conf t
hostname RouterA
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
no shutdown
interface Loopback0
ip address 10.1.1.1 255.255.255.255
router eigrp 1
network 10.1.1.1 0.0.0.0
network 192.168.1.0
no auto-summary
end

RouterB:
conf t
hostname RouterB
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
no shutdown
interface Loopback0
ip address 20.1.1.1 255.255.255.255
router eigrp 1
network 20.1.1.1 0.0.0.0
network 192.168.1.0
no auto-summary
end

RouterC:
conf t
hostname RouterC
interface FastEthernet0/0
ip address 192.168.1.3 255.255.255.0
no shutdown
interface Serial1/0
ip address 192.168.2.1 255.255.255.252
no shutdown
interface Loopback0
ip address 30.1.1.1 255.255.255.255
router eigrp 1
network 30.1.1.1 0.0.0.0
network 192.168.1.0
network 192.168.2.0 0.0.0.3
no auto-summary
end

RouterD:
conf t
hostname RouterD
interface FastEthernet0/0
ip address 192.168.1.4 255.255.255.0
no shutdown
interface Serial1/0
ip address 192.168.2.5 255.255.255.252
no shutdown
interface Loopback0
ip address 40.1.1.1 255.255.255.255
router eigrp 1
network 40.1.1.1 0.0.0.0
network 192.168.1.0
network 192.168.2.4 0.0.0.3
no auto-summary
end

RouterE:
conf t
hostname RouterE
interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.0
no shutdown
interface Loopback0
ip address 50.1.1.1 255.255.255.255
shutdown
interface Serial1/0
ip address 192.168.2.2 255.255.255.252
no shutdown
interface Serial1/1
no ip address
shutdown
router eigrp 1
network 50.1.1.1 0.0.0.0
network 192.168.2.0 0.0.0.3
network 192.168.2.4 0.0.0.3
network 172.16.1.0 0.0.0.255
no auto-summary
end

RouterF:
conf t
hostname RouterF
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.0
no shutdown
interface Loopback0
ip address 60.1.1.1 255.255.255.255
router eigrp 1
network 60.1.1.1 0.0.0.0
network 172.16.1.0 0.0.0.255
no auto-summary
end

ただ、トポロジ作って気づきましたけど、この問題の「収集した情報のルーティングテーブル」って間違ってないですかね?
環境作ってやってみたら以下のようなテーブルになって
Gateway of last resort is not set

     20.0.0.0/32 is subnetted, 1 subnets
D       20.1.1.1 [90/409600] via 192.168.1.2, 00:01:03, FastEthernet0/0
     172.16.0.0/24 is subnetted, 1 subnets
D       172.16.1.0 [90/2221056] via 192.168.1.3, 00:00:51, FastEthernet0/0
     40.0.0.0/32 is subnetted, 1 subnets
D       40.1.1.1 [90/409600] via 192.168.1.4, 00:00:56, FastEthernet0/0
     10.0.0.0/32 is subnetted, 1 subnets
C       10.1.1.1 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
     192.168.2.0/30 is subnetted, 1 subnets
D       192.168.2.0 [90/2195456] via 192.168.1.3, 00:00:58, FastEthernet0/0
     60.0.0.0/32 is subnetted, 1 subnets
D       60.1.1.1 [90/2349056] via 192.168.1.3, 00:00:56, FastEthernet0/0
     30.0.0.0/32 is subnetted, 1 subnets
D       30.1.1.1 [90/409600] via 192.168.1.3, 00:00:59, FastEthernet0/0
設問での5行目
D       172.16.1.0 [90/2174976] via 192.168.1.4, 00:00:51, FastEthernet0/0
は出ないはずですね。
だってRouterEのSerial1/1はshutdownされているんですから、172.16.1.0/24向けの経路は192.168.1.3から入手することになり自分がゲートウェイになれないですからね。
RouterE#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.1.1      YES manual up                    up
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial1/0                  192.168.2.2     YES manual up                    up
Serial1/1                  unassigned      YES unset  administratively down down ←ここ
Serial1/2                  unassigned      YES unset  administratively down down
Serial1/3                  unassigned      YES unset  administratively down down
Loopback0                  50.1.1.1        YES manual up                    up

RouterD#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.4     YES manual up                    up
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial1/0                  192.168.2.5     YES manual up                    down ←ここ
Serial1/1                  unassigned      YES unset  administratively down down
Serial1/2                  unassigned      YES unset  administratively down down
Serial1/3                  unassigned      YES unset  administratively down down
Loopback0                  40.1.1.1        YES manual up                    up


RouterD#show ip route
(略)
Gateway of last resort is not set

     20.0.0.0/32 is subnetted, 1 subnets
D       20.1.1.1 [90/409600] via 192.168.1.2, 00:09:37, FastEthernet0/0
     172.16.0.0/24 is subnetted, 1 subnets
D       172.16.1.0 [90/2221056] via 192.168.1.3, 00:03:51, FastEthernet0/0 ←ここ
     40.0.0.0/32 is subnetted, 1 subnets
C       40.1.1.1 is directly connected, Loopback0
     10.0.0.0/32 is subnetted, 1 subnets
D       10.1.1.1 [90/409600] via 192.168.1.1, 00:09:37, FastEthernet0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
     192.168.2.0/30 is subnetted, 1 subnets
D       192.168.2.0 [90/2195456] via 192.168.1.3, 00:03:56, FastEthernet0/0
     60.0.0.0/32 is subnetted, 1 subnets
D       60.1.1.1 [90/2349056] via 192.168.1.3, 00:03:56, FastEthernet0/0


はてさて、設問のRouterEのSerial1/1設定が間違っているのか、それともRouterAのルーティングテーブルが間違ってるのか…

投稿ツリー

  >フォーラム検索へ


Copyright (c) 2020 Ping-t All rights reserved.
ログイン
ユーザ名 or E-Mailアドレス:

パスワード:







Contact

LPI-Japan Logo

LPI Logo